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Overview

Datastream Advance gives you access to the world’s largest and most respected historical
financial numerical database. Advance provides a range of charting and reporting tools
that enable you to manipulate and display, or simply download that data in the way that
you want. With Datastream Advance you can also get a set of Microsoft Office add-ins
that enable you to access the Datastream database directly from within Excel, Word, or
PowerPoint - create and embed data requests that put the data you want straight into your
spreadsheet, document, or presentation.

Datastream’s data coverage

Unrivalled depth and breadth of coverage across the full range of instrument types means
immediate access to the data you need. Worldwide equity coverage direct from the stock
markets, comprehensive market indices, economics data direct from national government
sources as well as the OECD and IMF, fixed income securities and associated indices,
commodities and derivatives data. Forecast earnings data from IBES, fundamental data
from Worldscope and added value data sets from respected sources such as MSCI, DJ
Stoxx and FTSE All World. And all data is quality checked and actively maintained by
dedicated staff.
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Data selection 

Datastream Advance provides an easy to use interface with most options for standard
requests selectable by mouse click. Start by selecting a data category and follow this
sequence to generate the output you require:

Equities

Equity Indices

Unit Trusts

Investment Trusts

Bonds  and
Convertibles

Bond indices & CDS

Economic reports/
charts

Exchange rates

Interest rates

Commodities

Warrants

Futures

Options

Constituent lists

User created Indices

User created Local
lists

User created Time
series

Single Series --
Overview

Multiple Series
/Flexible Charts

Single Series- Chart

Single Series-Report

Single Series -Data

Codes  and
Information

Favourites

Scenario Testing 

Equity Screening 

Data Ranges

Datatypes

Currencies

View

Print

Export

Transfer to Excel

Advance for Office

Select data category . .

Select request . .

Output

Make adjustments . .



Starting Advance and Advance for Office (AFO)

Before you use Advance, or Advance for Office, your systems administrator should have configured
your communications link with the Datastream host. If you have any problems connecting to
Datastream, please contact your systems administrator, or see Configure Communications, Advance
Installation guide. 

Starting Advance

Double click on the Advance icon.
When Advance has loaded successfully, the Request screen is displayed.
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Closing Advance

To exit from the Request, Project, or Equity Search screen, select Exit from the File
menu.

Note:
Remember to save or export those reports, charts, and data that you want to use again
before you exit Advance.

Starting AFO

To use Advance for Office, open Office application and use the AFO drop down menu.

Closing AFO

Advance for Office closes when you close your Office application.





The Advance interface
The tool bar

Making a request 
Selecting a data category 

Selecting the series  
Using Datastream Navigator - series search

Selecting types of request  
Refining your request  

Dates
Datatypes  
Currency  

Making your request  

Using Advance
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The Advance interface

Advance Project tab

Link to Thomson Financial sites via browser, including Research Extranet access

Navigation Tool bar

Series selection

Datatype selection 

Chart or Report selection
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Currency selection

Results window

Settings button helps you to configure
the parameters for charts or reports

Date button
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The tool bar

Create a new Project. Specify a name for the new
Project when you Save the Project.

Open an existing Project. Choose from a list of
Projects, save the details of the current Project
before opening a new Project.

Save any additions or changes to the current Project.

Print the displayed request to the default Windows
printer. If you want to specify another printer or
change the printer settings, select File>Print to
display the Windows Print dialog.

Export a chart, or a selected area of data, or a
report in a format suitable for use with spreadsheets, word processors, etc.

Transfer the  data or chart request to Excel, for regular updating in Excel.

Create, edit, merge, or download lists from Datastream for generating
requests.

Display the Annotations tool bar. Click this button again to turn off the
Annotations tool bar. Use the Show Annotations option from the View menu to
show/hide any annotations added.
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Note: 

the Extranet can be configured in the Advance
options dialog (from the Tools menu) to be
displayed in the main window at start up.

Refresh the currently displayed request with the latest Datastream prices or values.

Refresh all requests in the current Project with latest Datastream prices or values.

Add request to Project for Scheduled Night Shift processing. Use the Add New Request button
to add any number of requests to a Project so all requests can be processed together when
you connect to Datastream.

Delete the displayed request from the current Project.

Datastream Research Extranet -
provides access to information to help
you get more from Thomson Datastream
- updates on new data, issues with the
data, user documentation and sample
Excel tearsheets.
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3Select a datatype (optional).
You can:

Click the Datatype Navigation
button to open Navigator.
See Datatypes, page 25.

2
Find and select your series. 

Click the Series navigation button to
open Navigator.

Check the Expert entry box and type
the exact mnemonic or code in the Series
field.
See Selecting the series, page 15.

1
Select the type of series you want from
the Data Category window- - holding the
mouse over the data category will
display quick links to Navigator.

See Selecting a data category, page 14.

4
Select the type of request.

Select a request type tab. For example, a
single chart.
Select the type of chart, report or data
format from the list displayed.

See Selecting types of request, page 20.

Making a request

To make chart, report, and data format requests, follow this sequence of steps to select
the data you require:



7View your results.
You can Print, Export, or Copy the results
of your request, and for a data request,
transfer the data to your spreadsheet
for future refreshing within Excel.
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6
Run your request.
Click the Run  Now button.
You can create a project and use the Schedule Night
Shift Facility to run your project at a later date.
You can save the parameters as a Favourite to save
you time setting up the details again.

See Making your request, page 28.

5
Refine your request.
Change the display period, select a relative date option
or click the Date button.
See Dates, page 22.

Change the currency, click the Currency drop down box. 
See Currency, page 27.

You can also make additional graph layout and data settings for
some requests using the Settings button.
See Settings, Advance User Guide, page 130.

To locate the series you want, you can use: the Find field, see Using Find, page 16; the Filter, see Using the Filter, page 18; and Equity
Search, see the Advance user guide, page 147.

For interactive step by step instruction, see the Advance 4.0 tutorial: select Advance
Tutorial from the Help menu.
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To select a data category:

Click the plus sign to expand the list and select a category from the list displayed.

Selecting a data category

Datastream series codes are stored in a database and are accessed using Datastream
Navigator. The series are grouped into 18 data categories, which are selected from the
Category drop down list. Selecting a data category gives you access to all the series
within that category.

You can select:

Equities
Equity indices
Unit Trusts
Investment Trusts
Bonds and convertibles
Bond indices & CDS
Economic reports and charts
Exchange Rates
Interest Rates
Commodities
Warrants
Futures
Options
Constituent lists
User created Indices
User created Local lists
User created Time series
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Selecting the series

Use Datastream Navigator to find and select the series you want, or if you know the
Datastream mnemonic or code, SEDOL, ISIN, or other Datastream supported code,
check the Expert entry check box and type the mnemonic or code in the Series field to
select your series.

Expert entry:

Check the Expert  entry box and
type the exact mnemonic or
code or Datastream function or
expression directly in the
Series field.

To select a series

Click the Series navigation button to find and select your series from Datastream
Navigator.
To view recent series use the drop down to select from the last 12 series used.
Check the Expert entry box and type the mnemonic or code in the Series field.

You can also use the Datastream Help Browser, see the Advance User Guide, pages 7-8.

Enter part of the name for the required series 
Click the Search button to open the Datastream Navigator.

Click the drop down button to view
and select recent 12 series



2

4Type the first few
characters of the name,
mnemonic, or code in the
respective field.

5
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Click the Search
button.1Click the Search button to

open Datastream  Navigator.

3Select the kind of
series you require.

Using Datastream Navigator - Series search

Series search is the most basic search. Use this to search by the name, DS mnemonic, DS code,
SEDOL, ISIN, local code, or IBES ticker of the series you are looking for. Alternatively you can use
the 'Explorer' hierarchies to drill down to the series (or the 'Help browse' pages that provide access
to the datatypes available for the series).

To find and select a series using Set Criteria page:

You can add a second
criteria of search

You can narrow down the
search by selecting different
other criteria like Market.

Click the Series  Search button
if it is not already selected.
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6Click on the series
that is required.

7The series is
displayed in Advance.

You can select related series and get
more data on the series using the flyout. You can export the list to

excel using Export to Excel
button



1
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Below example illustrates the steps to use Explorer to find a series.

Select Economics
data category.

2Click the Explorer link

Click the plus
sign to expand
the options
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Move the cursor over the flyout
button to obtain the options.
Click the Explorer option to know
where else in the hierarchies the
series is displayed.

Flyout button

poornima.rao
Note
MigrationNone set by poornima.rao

poornima.rao
Note
MigrationNone set by poornima.rao
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To select a request:

1 Select a request type node of the tree.
2 Select a request from the list displayed.

Selecting types of request

Advance gives you access to a wide range of reports, charts, summaries, overviews, and
comparison requests.

Over 100 Datastream reports, charts, and data formats are stored in Advance’s database.
You can access these by selecting a report/chart type node on the Request screen.

Charts or reports available.

Select a request type
node to further select the
request from the list
displayed.
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Multiple Series / Flexible Chart - You can display information on multiple series,
enabling you to create comparisons across different data category types, and use flexible
charts for multiple chart requests. For example, you can compare an equity with an index
such as the CAC40 and with an economic series such as the RPI.

Single Series - Data - You can download time series, static, and company accounts data,
which you can export or transfer to your spreadsheet.

Codes and Information - You can use the Remote Search as an alternative way to find
codes for active and dead equities, unit, investment trusts, bonds, warrants and convertibles.
There is also an option to set Advance to run requests and update projects in English,
French and German.

Favourites - You can save frequently used projects as Favourites so that next time you can
run the request quickly.

Single Series - Report - You can select from a range of pre-formatted report types
including Profit & Loss, Dividend & Earnings, Key Accounts Ratio, and Company
Profiles.

Single Series - Chart - You can request any of the standard Datastream graphics,
including Line, Moving Average, Stochastics, High-Low-Close, Candlesticks, and
Bollinger Bands.

Single Series - Overview - You can request Datastream company, commodity, warrant,
trust, and bond performance overviews, and a range of fixed format IBES forecast
overviews.

Request types:

Scenario Testing - use the intuitive interactive charting interface to graphically explore
trends and relationships between any of the series on Datastream.

Equity Screening - search the Datastream global equity universe for companies that
match your chosen criteria
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Relative dates.

1Click the Time  Period
button. The Configure  Dates
dialog is displayed.

Refining your request

Dates
Each data category has a default date range. You can choose your own from four display period
options:

Fixed start and end dates - a fixed period. For example, the whole of last year.
Relative start and end dates - a fixed period relative to today’s date.
Datastream base date - a period starting with the date of the earliest data available on the
database for a series.
Today - a period ending with the latest available price or value.
Intra-day prices are available for many markets. To receive the latest intra-day price or
value, you must subscribe to the intra-day service.

Advance enables you to combine these start and end date options.

To select a date period:
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Year ends - to
request the number of
year ends for company
accounts reports and
data.

Today's date option.
(To receive the latest
intra-day price or value,
you must subscribe to
the intra-day service)

Base date option.
Displays data from
the earliest date
that data is available.

Relative date option.

Fixed date option.
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2Select the date
options.

Fixed  date  option

Relative  date  option

To specify year ends
for Company Accounts
Report only.

Use the spin buttons
to select a date.

Select day, week, month, quarter or year.

To select both start and end
dates after today, for
projected series.

Click OK.

Type a date.

Use the spin buttons
to select a date.

Click the Calendar  button to display
an interactive calendar.

To select both start and
end periods before today.
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Datatype navigation button.

1Click the Datatype
navigation  button.
Datastream
Navigator is
displayed.

Datatypes

The datatype defines the type of data. For example, the default datatype for equities is
Price (Adjusted).

For some data categories and report/chart types, you can select the datatype. For example,
for an Equity line chart request you can change from the default Price (Adjusted) datatype
to Market Value.

When the Datatype navigation button is enabled, click to display the datatypes available
for your data category.

Datatypes are grouped by their type; for example, Datastream time series, static, company
accounts, IBES datatypes, MSCI datatypes, and Worldscope data items.

To select a datatype:

2Select Name or
Mnemonic from the
find drop down box.

3Select Equals
Starts With or
Contains from the
drop down box.

Check this box if default
datatype is required.
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5 4Type the search
criteria.

Select the type of
datatype, Static or Time
Series.

6Select the group
of datatypes to
select from.

7Click the Filter  /
Search button.

8 9Select the datatype from the list
displayed.
The datatype is displayed in
Advance.

Check the Navigator
definition to ensure that
the correct datatype
has been selected
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Currency

You can select which currency you want to display your results in.

Click the Currency drop down list and select
a currency from the list displayed.

Note:
The parameters that you can change are dependent on the data category and chart,
report, or data format chosen. For example, you can change the date, datatype, and
currency for an Equity - Line Chart request, but only the date for a Constituent - Bar
Chart request. If you cannot change the currency, the currency option is greyed out.
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Making your request

Once you have selected the criteria for your request and made your display date,
datatype, and currency adjustments, you can make your request:

Run Now: Request the report, chart, or data straight away. 

This connects you to Datastream and displays the result.
You can change the request criteria and click the button
again, or save the request for future use.

Note - 

double clicking on the request in the Explorer hierarchy will also run the request.

Add New Request: Add the request to the open Project to refresh later.

This does not connect you to Datastream, but stores the
request in the open Project. This enables you to work off
line and send all your requests at the time of your choice.

Please see Using Projects, Advance user guide, pages 92-95





Using your results
Printing reports, charts, and data 
Copying reports, charts, and data  

Transferring charts to MS Office 
Exporting charts, reports, and data 
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When you request reports, charts, and data formats from Datastream, they are displayed
within Advance and are automatically added to the current open Project. You can:

Print your charts and selected pages of reports through any Windows printer.

Copy reports, charts, and data formats to the Windows clipboard for further use in
Windows applications.

Export reports, charts, and data in a variety of formats for use with other applications
such as word processors.

Transfer data to Microsoft Excel. Data downloaded from Datastream can be
transferred to spreadsheet for regular updating.

Transfer charts to Microsoft Office applications like Excel, Word, and PowerPoint.
You can transfer your chart requests directly into these applications as embedded,
dynamic objects. Once embedded, the requests can be refreshed, and within Excel
and PowerPoint - you can right click on the chart to re-edit the chart in Advance -
then transfer it back, with any edits, to Excel and PowerPoint.

Using your results     
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Printing reports, charts, and data

You can print any displayed report, chart, or data format through the default Windows
printer, (in addition you can print a set of charts with several charts on page using the
Print Project (Chart Layout) option).

To print your report, chart, or data:

Select Print from the File menu, 
OR 
click the Print Current Request button,             to print the request displayed.

To change the printer or printer settings, select Print Setup for either Report or Chart
from the File menu.

ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED 
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Copying reports, charts, and data

You can copy the displayed report, chart, or data format to the clipboard and paste it into
other Windows applications.

To copy a report:

1 Select the area to be copied; this can be:
A range of cells - click the left mouse button and drag the cursor over the display
area to define the cell area to be copied.
The whole report (default) - the whole report is selected automatically when it is
displayed.

2 Select Copy from the Edit menu.

Note:
The report text will be held on the clipboard in text format with TAB formatting, but
without font and text formatting.

To copy a chart:

Select Copy from the Edit menu.

Note:
The chart will be held on the clipboard as a Windows Meta File.
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To copy data:

1 Select the area to be copied; this can be:
A range of cells - click the left mouse button and drag the cursor over the
displayed spreadsheet to define the cell area to be copied to the clipboard.
All the data (default) - the whole data request is selected automatically when it is
displayed.

2 Select Copy from the Edit menu.

Note:
The data selected will be held on the clipboard in text format with TAB delimiting for
direct pasting into a spreadsheet or word processor.

You can use the right click menu to copy.
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Transferring charts to MS Office

Chart requests can be transferred directly into Excel, Word, and PowerPoint as
refreshable objects.

To transfer a chart request to MS Office:

1 Select Transfer to Excel (Word, PowerPoint) from the Tools menu. Excel (Word,
PowerPoint) is opened with a new worksheet (document, slide).
Your chart is displayed.

2 You can display the chart: 
as a single element
OR
as an Office Picture - right click and select Display as Office Picture.
This gives you the Office Picture format options.

Note:
To display the chart as transparent, right click over the Refresh button and de-select
Display original background (the chart format must be as an Office Picture). To re-edit a
chart once transferred to Excel or PowerPoint - right click on the chart and select the
Edit Chart option.

You can use the right click menu to transfer and export.
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Exporting charts, reports, and data

You can export the displayed report, chart, or data as a file in a format suitable for use
with other software packages. The default formats are: .XLS (Excel spreadsheet) for
reports and data, and .WMF (Windows meta-file) for charts.

To export a chart, report, or data:

1 Select Export from the Tools menu.
The Export Viewport As dialog is displayed.

2 Select the export details:
Type an export file name
Select a drive or a server destination
Select an export format

3 Click OK.





Using Advance for Office
The Advance for Office (AFO) interface 

Making a static request 
Making a time series request 
Using the Request Manager 
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The Advance for Office (AFO) Interface

To use Advance for Office, use the Datastream AFO menu in your Office application.

AFO menu in Excel.

AFO menu in PowerPoint.

Using Advance for Office
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Time  series  requests
To request data over a
specific period, defined by a
start date, end date, and
frequency of data.

For example, the daily price
for Pepsico from 01/01/05
to 01/01/06

Static  requests
To request data for a specific date.

For example, the price, PE and dividend yield
for Pepsico and Coca-Cola for 01/01/05

In AFO you can make static, time series, and company accounts requests.

Using Advance for Office

Request  Manager
Use the Request Manager to manage your
embedded requests.  All the chart and data
requests in your Excel work book are listed with
their details.  You can edit, delete, or refresh
the requests individually or together.

ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED G

Note:

Since the replacement of Datastream company accounts with the
normalised Worldscope fundamentals database - fundamentals data
can now be retrieved using Static and Time Series requests. 
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2Select the series.
Click the Series
navigation button to
display Datastream
Navigator.

The series chosen
is displayed in the
Series field.

You can also
select lists of
series, and
expressions.

Select the series you
want from the list. See
Selecting the series,
page 15.

1Select Static
Request from the
AFO menu.

You can choose
either DS ISIN etc
or Thomson One
code as input to
the series

Making a static request
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4

The datatypes
chosen are displayed
in the Datatype field.

3Select the datatype.
Click the Datatype
navigation button to
display Datastream
Navigator.

Select the datatype
you want from the
list. See Datatypes,
page 25.

Currency
option helps
you to choose
the currency



5
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6

Select the date.
Type the date of the
data you want in the
Date field in the format
dd/mm/yy, or as a
relative date from today. 

For example, -6m for 6
months ago from today.

Select the display
options.

Row  Titles
Displays the series code at the
left of each series.

Column  Titles
Displays the datatype mnemonic
or expression at the top of the
column for each datatype.

Headings
Displays a general heading for
row and column headings. For
example, the date of the
request.

Currency
Displays the traded currency for each
selected series.

Expression
Display the expression description or
number.

Transpose
Displays the series data in rows instead
of columns.

Display  Thomson  ONE  code
Displays the Thomson ONE code for the
series selected.

Embed
The request is embedded as a dynamic, refreshable object when
saved. If this is not selected, the results cannot be refreshed.

Auto  Refresh
Refreshes the request automatically when you open the
spreadsheet.

Visible  button
Displays the Refresh button with the request results. You can
use the Request  Manager to refresh requests, see page 50.

Trigger  in  Cell
Select this option to run the request again if contents of the
referenced cell change.
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The values for the datatypes selected are displayed for the date selected.

To refresh the request, click on the Refresh button.
To edit the request, right click on the button and select the
Edit option

7Click the Submit
button to make the
request.
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2Making a time series request

The series chosen
is displayed in the
Series field.

You can also
select lists of
series and
expressions.

Select the series you want
from the list. See Selecting
the series, page 15.

Select the series.
Click the Series  navigation
button to display
Datastream  Navigator.

You can choose
either DS, ISIN
etc or Thomson
One code as input
to the series

1Select Time  Series
Request  from the
AFO menu.
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1Select Time  Series
Request  from the
AFO menu.

2

Or to display time series for a list of series

Click on the List
Picker button

Click on the List you
reqiure and click OK.

Click TS  for  each  item
in  the  list to get Time
Series for each item.
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4Select the datatype
you want from the
list. See Datatypes,
page 25.

3

The datatype
chosen is displayed
in the Datatype
field.

Select the datatype.
Click the Datatype
navigation button to display
Datastream  Navigator.

Currency
option helps
you to choose
the currency
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Row  Titles
Displays the series code at the
left of each series.

Column  Titles
Displays the datatype mnemonic
or expression at the top of the
column for each datatype.

Headings
Displays a general heading for row
and column headings. For example,
the date of the request.

Currency
Displays the traded currency for
each selected series.

Expression
Display the first series mnemonic or
description.

Transpose
Displays the series data in rows
instead of columns.

Display  Latest  Value  First
Displays the most recent value
first

Embed
The request is embedded as a dynamic, refreshable object when
saved. If this is not selected, the results cannot be refreshed.

Auto  Refresh
Refreshes the request automatically when you open the
spreadsheet.

Visible  button
Displays the Refresh button with the request results. You can use
the Request  Manager to refresh requests, See page 50.

Trigger  in  Cell
Select this option to run the request again if contents of the
referenced cell change.

5

6

Select the date.
Type the date of the data
you want in the Date field in
the format dd/mm/yy, or as
a relative date from today.
For example, -2Y for 2
years ago from today.

Select the display
options.
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The values for the datatypes selected are displayed for the date selected.

To refresh the request, click on
the Refresh  button.

7Click the Submit
button to make the
request.
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1 2Select Request
Manager from
the AFO menu.

Select the request
and click the
appropriate button to
Goto, Edit, Delete, or
Refresh the request.

Click to turn
Autorefresh on or
off for the selected
requests.

Select either data
or chart requests.

Click to select all the
requests displayed.
This is useful if you
want to refresh, or
delete, all requests.

Click to refresh the data
in the selected requests.

Click to locate and
display the
selected request
in the worksheet.

Click to delete the
selected request.

Click to display the
Request  Details  dialog
for editing.

Using the Request Manager

Use the Request Manager to manage the requests in your worksheet. The Request
Manager lists all the requests in your worksheet. You can find, edit, refresh, and delete
requests.
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3

4
5

To edit a
request, for
example, select
the request you
want to edit.

Click the Edit
button.
The Request
Details dialog  is
displayed.

Make your
changes and click
Submit. The
original request
is overwritten
with the new one.





Worked examples
Creating Advance lists 

Creating a flexible chart 
Creating an index

Creating an equity screen
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2 3Select the Local
Lists  data
category.

1Click the User
Created option in
Data  Category
window

Click the List
Wizard  button.

Creating Advance lists

Lists are a good way to make report, chart, and data requests for group of series that you
use frequently. Instead of making individual requests, you can make one request to get
results of all the series you are interested in. Once you have created your lists, you can
edit them to reflect any changes in the group of series. You can use the Request or Project
screens to refresh your lists in Advance, or the Request Manager to refresh them in AFO.

This worked example shows you how to create a list of series. For more information
about lists and what you can do with them, see the Advance User Guide, pages 21 - 33.

Creating a list of Automobile companies
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4

5Click the Next button.

Select Create  a  new  list.

6Click the Series  navigation
button to display
Datastream Navigator.
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8

11Click Use  Selected  Items
to include them in the list.

7Search for the
series you want
in your list.

Click the Explorer option in
the flyout to display related
series



10

9
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Click the check box to
select the series. 

Click the View
Selected link to view
the selected series.
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14Click the Finish button.
Again there is an option to
remove the series from
the list. Click the minus sign
to remove the series.

12Click Next.

Select the Upload option to add the list to the Datastream
database, where it is stored as an L# list. You can also save
as a UCI (X#) list
If you do not upload, the list is stored on your local drive or
server.

13Type the description
and name for your list
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3

4Select the series.
See Selecting the
series, page 15.

Creating a flexible chart

Flexible chart enables you to create multi-graph charts. This example shows you how to
create a chart of three graphs showing the performance of Coca-Cola and Pepsi.
It includes a Price chart against the S&P 500 index for non-alcoholic beverages, a
Dividend Yield chart, and a Market Value chart.

Select the data
category. Equities for
Coca-Cola and Pepsi, and
Equity  indices for the
S&P 500 Index.

5Select the datatype.
See Datatypes, page 25.

8Select the date.
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7
Repeat steps 3-5 for each series, you
should have: 
Coca-Cola - Price
Pepsi - Price
Coca-Cola - Dividend Yield
Pepsi - Dividend Yield
Coca-Cola -Market value
Pepsi - Market value
S&P EUROPE 350 FOOD BEV & TOB -
Price Index

1Select the Multiple
Series/Flexible  Chart
node.

6Click the Add  button to add the
selected series to the list , with the
required datatype (Remember the last
series and datatype dropdowns allow
these to be easily re-selected)

2Select Flexible  Chart..
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9

11

10

Select three graphs
and click OK.

Click the Change  Chart
Layout  button.
The Customise  Chart
Layout  dialog is displayed.

Click the Settings
button.
The Flexible  Chart
Wizard is displayed.
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13

12

14

15

Type the Chart Title.

Click the Properties button.
The Properties  for  Graph  1
dialog is displayed.

Select the Series for
Graph 1 and add them to
Graph 1.

Click Next.
The Assign  Series  to
Graphs  dialog is
displayed.
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18

19 20Click OK.

Graph  Settings

Select Use my Graph Title
and type your graph title.

Select the data Frequency.

16Select the Series and
Graph Settings for
Graph 1.

17Series  Settings

Select the type of chart
for each series: Composite
bar chart.
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21Select the Series and
Graph settings for
graphs 2 and 3.

Line Chart

Select Use my graph title
and type the title.

Rebase to 100 for graph 2.
(Do not rebase graph 3)

22Click OK.
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23Click Finish.

24Click Run  Now
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You can:

Change the chart properties: Right Click on the chart and select Properties... - then select Icharts from the

Scheme dropdown at the top

Edit the chart settings; click the Settings button

Edit the chart using Annotations; Click Annotations  icon          in the tool bar.

Save the flexible chart as a Project; select File>Save  As

Transfer or Export it; select Tools>Transfer or Tools>Export

For more information, see the Advance User Guide, pages 71 - 91.

The results are displayed.
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Creating an index

The UCI  Manager enables you to create and maintain your own indices. Each index is
based on a list of constituent series, which you specify as the first step of creating an
index. Once created, an index can be automatically maintained for you, with new values
calculated daily.

This worked example shows you how to create an index list and how to calculate it as a
trial index. For more information about user created indices and what you can do with
them, see the Advance User Guide, pages 34 - 41.
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1Select UCI  Manager from the
Tools menu Or from the UCI
Manager option in the
Datastream-AFO menu in Excel. 2Select Create  new  list.

The List  editor is
displayed.

3Click the Series
navigation button to
display Datastream
Navigator to select
individual equities or an
index constituent list 

You can also select a
local or user list: click
the List  picker  button.

List mnemonic.

List description.

Creating an index list of beverage companies
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4
Search for your series, see
Selecting the series, page 15.

Click on the mnemonic to
select it from the list
displayed. 

5Repeat step 4 until
you have selected all
your series.

Close Navigator.

You can use the Remove,
Clear selection, and Invert
selection buttons to
amend your list.

6Click the Save button
to save your list. 
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2Type or select the Base  date and the Base
value. 
The Base date is the date for the starting
value of the index. 
The Base value is the starting value for the
index, typically 100 or 1000.

Calculating a trial index of beverage companies

This example calculates a Trial index. A trial index is an experimental or one off
calculation. This is usually calculated within an hour and is not updated by Datastream.
An auto index is calculated automatically, by Datastream, every 24 hours. This is first
calculated the day following your initial request and then every 24 hours.

1
Click the Request
calculation button.

The Calculation
request screen is
displayed.
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4Select the type of
Calculation: Trial or
Auto. In this case
select Trial. 5Select the

Currency for
the index.3Type or select the End  date

(optional) for trial indices. 
For auto indices calculations
are made to the latest date
for which data is available.6Click the Submit

request button. 
Your index is sent
for calculation.
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7
While your index is being
calculated, the status is
shown as Trial  Pend. Click
the Refresh button on
the details screen to
check on the status.

8
When your index is
calculated, the
status is shown as
Trial. 
When you are happy
with your index, you
can calculate an auto
index.
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2Click the
New  Search
button.1Select the Equity

Screening tab.

Creating an equity screen

Equity screening enables you to search the entire global equities database of over 60,000 stocks,
or across a region, such as the euro zone, or a single market. You can store your search to edit
and re-run at a later date. You can save the results in a list for analysis in Datastream Advance
or AFO.

For more information about equity screening and what you can do with them, see the Advance
User Guide, pages 102 - 121.

Creating an equity screen
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3Select France
from the
Country tab.

4Click the Add
button.

5Click the Next
button.
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7Select the limitations:
over 1 Billion.

9Click the
Industry  &
Sector
Mnemonic tab.

6
Click the Datatype
navigation button to
search for and
select a datatype.
See Selecting a
datatype, page 25.

8Click the Add
button.
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10Select automobiles from
the Find  equities  in  1st
industry box. 11Select auto

parts from the
2nd  industry
box.

12Click the Add
button

13Click the Sort
Order  &  Currency
tab.
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14Select euro from the
Currency box.

16Click the Search
Now button.15Select Ascending

and Market  value.



DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERS

ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED 

78

17Click the Save  As
List  button.
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18Type the file name and
description for your
search and click the Finish
button.

Click the Upload
button to save your
search on
Datastream.
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Advance lists

Advance provides flexibility in creating lists of series, such as a portfolio, a watch list, or
a set of related indicators. One can analyse the series as a set or individually. Lists are a
convenient way to make report, chart, and data requests using multiple series. One can
create copies of Datastream’s index constituent lists, remove unwanted series, reorder the
list, or merge two lists to create one. The List Wizard takes you through the process
effortlessly. For a worked example, see page 54.

User guide: Advance User Guide, pages 21 - 33.

Online help: Select Help>Contents>Advance facilities>Lists, 
OR
Click the Help button on the list wizard dialog box. 

Expressions and functions

Advance’s expression picker gives you access to over 50 standard functions and
expressions, which one can use to form part of one’s chart, report, or data requests. For
example, find the percentage change in share price over 12 months.

Advance’s expression builder enables one to create and edit one’s own expressions,
which one can keep and access through the expression picker for future use.

User guide: Advance User Guide, pages, 46 - 58.

Online help: Select Help>Contents>Advance facilities> using expressions and 
functions, 
OR 
Click the Help button on the expression picker, or expression builder
dialog boxes.
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Flexible charts

Flexible chart gives one the freedom and flexibility to create one’s own tailor-made chart
layouts. Advance provides for comprehensive customisation of all aspects of one’s
graphs. 

Flexible Chart is particularly good for creating multiple chart layouts with multiple series
using a variety of different chart types and styles. For a worked example, see page 59.

User guide: Advance User Guide, pages 71 - 91.

Online help: Select Help>Contents>Flexible Chart

Projects

Advance Projects enable one to save one’s analysis and automate  printing and exporting
charts. 

One can schedule projects to update at a future time and to print or export the updated
requests in a range of graphics or spreadsheet formats.

User guide: Advance User Guide, pages 92 - 95.

Online help: Select Help>Contents>Advance facilities> Projects
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Schedule Night Shift

Advance scheduling enables you to refresh your projects at a future time and on a regular
basis. For example, you can refresh your projects overnight giving you access to updated
charts, reports, and data the following morning.

User guide: Advance User Guide, pages 98 - 101.

Online help: Select Help>Contents>Advance facilities>Schedule Night Shift

Equity screening

Equity screening enables you to search the entire global equities database of over 60,000
stocks, or across a region, such as the euro zone, or a single market. You can store your
search to edit and re-run at a later date. You can save the results in a list for analysis in
Datastream Advance or AFO. For a worked example, see page 73.

User guide: Advance User Guide, pages 102 - 121.

Online help: Select Help>Contents>Equity screening
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Customising charts and reports

You can customise your charts and reports using properties and annotations. You can
change the text, line, and fill styles, and save your styles in a template for future use.

User guide: Advance User Guide, pages 59 -70.

Online help: Select Help>Contents>Advance facilities>Annotating charts and
reports 

Web browser

The embedded browser links you directly to user support through the Datastream
Research Extranet.

User guide: Advance User Guide, pages 122 - 131.

Online help: Select Help>Contents>Web browser 
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Favourites

Favourites enables you to store your chart or report request with its settings, for example,
dates, datatype, currency, etc. You can save them with unique names and select them from
a drop down list.

User guide: Advance User Guide, page 97.

Online help: Select Help>Contents>Advance facilities>Favourites

AFO request table

The request table enables you to manage groups of refreshable requests. You can view the
details of all your requests together. You can schedule the table to be updated at a future
time or overnight. You can select which requests you want to update. 

User guide: Advance for Office - Excel User Guide, pages 30 - 38.

Online help: Select Help>Contents>AFO request table
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User created indices

The UCI  Manager enables you to create and maintain your own indices. Each index is
based on a list of constituent series, which you specify as the first step of creating an
index. Once created, an index can be automatically maintained for you, with new values
calculated daily. For a worked example, see page 67.

User guide: Advance User Guide, page 34 - 41.

Online help: Select Help>Contents>Advance facilities>Favourites

User created time series

A user time series is a series of values (data) for different points in time created by you
and uploaded for storage on Datastream. The values can be daily, weekly, monthly,
quarterly, or yearly and you can save the series in management groups to help you
organise them. You can use these series in Advance and AFO charts and reports. You can
combine them with Datastream maintained series and use functions and expressions to
manipulate them. An Excel template is used to create and edit your time series. You can
download an existing series to form the basis of a new one.

User guide: Advance User Guide, page 42 - 45.

Online help: Select Help>Contents>Advance facilities>Favourites
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Getting started - A brief guide to getting started with the basics of Advance
User guide - A comprehensive guide to Advance and how to use it 
Reference - A reference guide to the menus, options, and tools 

Further support

Advance has a comprehensive documentation set to support you. This comprises a
complete set of manuals, online help, and interactive tutorials to get you started.

Manuals

A complete set of Advance 4.0 user guides is available from the Help menu, select
online manuals. These are provided as fully bookmarked Adobe Acrobat PDF files. You
can browse, select, read, and print the sections you are interested in.
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A complete set of AFO 4.0 user guides is available from the AFO menu in Excel, Word,
and PowerPoint: select Online Manuals.

Introduction - An overview of Advance for Office (AFO)
User guide Excel - A comprehensive guide to using AFO with Excel
User guide Word - A comprehensive guide to using AFO with Word
User guide PowerPoint - A comprehensive guide to using AFO with PowerPoint



DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERSION 4.0, ISSUE 2 DATASTREAM ADVANCE VERS

92

ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED GUIDE ADVANCE GETTING STARTED 

1
Select Contents
from the Help menu.
The Online  Help
opening screen is
displayed.

Online Help

A comprehensive online help system is available from the Help menu: select
Contents. You can also access context sensitive Help from most of the dialog
boxes within Advance.
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Telephone support

Datastream provides fully resourced Help desks for queries on Advance, data, and
communications problems.

Account management

In addition to the service provided by the Help desk, full advice and support is available
from your Account Manager. 

Datastream Research Extranet support site

The Extranet contains information on new content and functionality, series code updates
and an increasing range of spreadsheets, documents, and presentations showing how
Datastream charts and data can be used in Excel, Word, and PowerPoint.

Training

Datastream provides a range of hands on training workshops designed to give you the
knowledge, practice, and confidence to make full use of Advance. Contact your
Account Manager for complete and up to date information. 

Contact details

For current numbers and addresses, see the Extranet:

http://product.datastream.com/extranet
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